Zur Navigation

isp-11.ch

1 Christian

Salve

Nur 2 Fehler im Code bei der Validierung! Ihr könnt stolz auf Euch sein!

# Error Line 59 column 142: required attribute "ALT" not specified.

...idmailer-1.gif" hspace="5" border="0"></a>

The attribute given above is required for an element that you've used, but you have omitted it. For instance, in most HTML and XHTML document types the "type" attribute is required on the "script" element and the "alt" attribute is required for the "img" element.

Typical values for type are type="text/css" for <style> and type="text/javascript" for <script>.

# Error Line 60 column 183: required attribute "ALT" not specified.

...88" height="31" hspace="5" border="0"></a>


Wer gibt mir den entscheidenden Tipp?



En Gruess us dr Schwiz!

24.04.2006 14:35

2 Jörg

Hallo Christian,

beim img Element ist das alt Attribut obligatorisch, welches einen alternativen Text enthält, der das Bild beschreibt:

...88" height="31" hspace="5" border="0" alt="Bildinhalt"></a>

Falls das Bild nur dekorativ ist, kann das alt Attribut auch leer sein:

alt=""

24.04.2006 14:57 | geändert: 24.04.2006 14:58

3 Christian

Viiiiieeelen Dank!

En Gruess us dr Schwiz!

24.04.2006 15:00

4 Christian

Sodele . . validiert und ohne target-Attribut stelle ich Euch das Redesign von ISP-11 vor. Kleine Einschränkung, es ist meine erste, persönlich gemachte, Seite mit einem css-"Design". Es werden noch einige Böcke zu finden sein. Insbesondere die Validierung des CSS-Sheet's scheint noch eine Menge Arbeit zu machen.


Guckt mal rein, schliesslich ist auch ein Haufen Arbeit von Euch mit drin!

En Gruess us dr Schwiz!

24.04.2006 19:55

5 C)-(iLL@

Hallo Christian,

aller Anfang ist schwer, und das ist ein guter Anfang.

Es werden noch einige Böcke zu finden sein.

Ja. Ein kleiner Validator-Fehler mit einem <p>-Textblock, und die font-tags. Danach könntest Du doch gleich XHTML Strict nehmen, oder? :)

24.04.2006 20:07

6 Christian

Ein kleiner Validator-Fehler mit einem <p>-Textblock, und die font-tags.

Wo, mir hats nichts angezeigt . . bei meinem Test war "tutti in ordere" . .

En Gruess us dr Schwiz!

24.04.2006 20:10

7 C)-(iLL@

Wo
na da :) N.B: Das mit den font-Tags habe ich gesagt, weil nur die noch daran schuld wären, dass die Seite nicht in XHTML Strict validieren würde (ok, die einfachen Elemente ohne schließenden Tag müssen einen / vor dem > bekommen, z.B. <br /> anstatt <br>, <img ... /> anstatt <img...>,<meta ... /> statt <meta...>, aber daran sollte es nicht scheitern ^^

24.04.2006 20:12 | geändert: 24.04.2006 20:17

8 Christian

Danach könntest Du doch gleich XHTML Strict nehmen, oder? :)

Sodele . . <p>, da seid Ihr Schuld! Ich hätte nie den banner von diesem Forum eingefügt, wenn Ihr nicht so gierig aufs Helfen wärt! Das ist scheinbar noch so reingeflutscht nach dem validieren . . .

<font> sind weg, dafür gibt jetzt h3 eine Fehlermeldung! Was soll denn das?? Irgendwie sollte ich da <span> nehem oder sonstwas, in einem <a> darf das scheinbar nicht eingeschlossen werden, hm?

Was ist die Hürde für strict?

En Gruess us dr Schwiz!

24.04.2006 20:22 | geändert: 24.04.2006 20:25

9 C)-(iLL@

Was ist jetzt passiert? Du schachtelst Headings (hx) in den Anchors (a) - Wenn geht das nur umgekehrt, also <h3><a>...</a></h3>, nicht <a><h3></h3></a>.

Zu XHTML-Strict gibt es nur kleine Hürden, wie die genannten Slashes / (die würde ich mal als erstes umstellen, Doctype natürlich auch):

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN">
und wahrscheinlich einige Layout-Attribute wie img:hspace müssen raus und ins CSS.

24.04.2006 20:29

10 Christian

kleine Hürden . . . grins . . ich nehm zuerst mal die kleine Hürde der anderen Seiten, danach das CSS . . ich glaube, das sieht ziemlich schlimm aus dadrin . . .

Danach . . mal gucken!

En Gruess us dr Schwiz!

24.04.2006 20:44