Zur Navigation

Site-Check

1 kadees

So, jetzt will ich mich hier auch mal zerpflücken lassen.
Anlass ist der geplante Relaunch meiner Site, der Entwurf ist zu finden unter kadees.kilu3.de.

Kritik, Meinungen, Fehlerberichte sind jederzeit willkommen.

Gruß Dieter

01.09.2007 20:26

2 Jörg

Hallo Dieter,

farblich macht die (Start-)Seite einen ganz guten Eindruck auf mich und von der technischen Seite scheint sie mir sehr sauber umgesetzt :).

Ein Problem habe ich allerdings mit der Navigation. Von der erwarte ich eigentlich auch, dass sie mir etwas Orientierung gibt. Leider ist sie auf deiner Site etwas unbeständig: auf den Unterseiten findet man nur die weitere Verzweigung des betreffenden Bereiches, aber nicht mehr die andren Bereiche (Tipps und Tricks, Templates, Links) und das Startseiten-Symbol ist eher unscheinbar und abseitig, so als ob das Symbol nicht zur Navigation gehört. Auf weiterführenden Seiten ist die Navigation gar nicht mehr vorhanden. Gerade bei unbekannten Sites schau ich hin und wieder auf die Navigation, um zu sehen, wo ich mich gerade befinde und was es noch für Bereiche gibt - aber auf deiner Site muss ich mich erst wieder hochklicken zur Startseite, um den Überblick zu haben

02.09.2007 09:44

3 Elvis

Zitat von Jörg
Ein Problem habe ich allerdings mit der Navigation. Von der erwarte ich eigentlich auch, dass sie mir etwas Orientierung gibt.
Meinem Auge ist sie einfach nur etwas zu klein, bzw. zu unwichtig. Die Navigation sollte mehr ins Auge stechen.

Optisch ist die Seite ansonsten gelungen. Wenn es dann keine Baustelle mehr ist, würde ich einen neuen Text für die Startseite schreiben und die News auf eine Unterseite verbannen.

Den Code hab ich mir jetzt nicht angeschaut.

Ich hab jetzt auch endlich einen sinnlosen Weblog....

02.09.2007 11:40

4 kadees

Hallo Jörg,
Das mit der Navigation ist mir klar, zur Beruhigung: Es ist eine Navi im Header geplant btw. eigentlich fast fertig, nur optisch passts noch nicht! Das kleine 'Home' Symbol ist nur eine temporäre Notlösung.

An Alle:
Bitte auch mal einen Blick auf den Code werfen!
Kritik jederzeit erwünscht.

Gruß Dieter

02.09.2007 14:43

5 Rudy

Zitat von http://kadees.kilu3.de/tipps/tipp_003.html

absolut positioniert - feste Höhe und Breite [...]
Ist das Browserfenster kleiner als die Box, wird der Inhalt abgeschnitten ohne dass man die Möglichkeit hat in die verdeckten Bereiche zu scrollen.
Ich habe hier mal eine Methode gepostet, mit der eben dieser Effekt nicht auftritt. Zentrierungen in jeder Auflösung

Der Code Deiner Site ist ok :) Ich bin sicher, darauf hast Du auch geachtet, find ich gut.

02.09.2007 16:31

6 kadees

So,
hab jetzt die Topnavi eingebaut, wie gesagt, an der Optik muss ich wohl noch feilen.

Beim Crossbrowsercheck ist mir folgendes aufgefallen:
Firefox und Opera zeigen alles an wie ich mirs vorstelle.
IE7 weigert sich sich standhaft in der Top-Navi beim hovern den weissen Hintergrund anzuzeigen.
IE6 und IE5.5 zeigen die Infoboxen aus der linken Navi nicht an, dafür den weissen hover-Hintergrund in der Top-Navi.
IE5.01 zeigt beides!
Safari / Win unterstreicht den Text in den Infoboxen.

Vielleicht habt ihr mir einen Tipp, gerade zum IE7, IE6 und Safari? (Der Rest ist mir schnuppe!)


Gruß Dieter

02.09.2007 16:37

7 kadees

@Rudy:

Beispiel 3: mit float und clear

Aber Danke für deine Antwort ;)

EDIT: ich stelle dort drei Möglichkeiten vor, einen CSS-Container horizontal und vertikal zu zentrieren.
Bei den Beispielen 1 und 2 sind sind halt die Nachteile ganz klar dargestellt. Wenns jemand trotzdem verwenden will: seine Sache!

Gruß Dieter

02.09.2007 16:40 | geändert: 02.09.2007 16:47

8 Jörg

Zitat von kadees
Safari / Win unterstreicht den Text in den Infoboxen.

Ja, selbes Verhalten im Konqueror - aber die beiden sind ja auch verwandt.

Es scheint so, dass in Konqueror die text-decoration in "#sidebar a.info:hover" nicht von der in "#sidebar a.info:hover span" überschrieben wird, sondern dass erstere nur hinzuaddiert wird: wenn man z.B. im zweiten Selektor "overline" statt "none" wählt, erhalten die Texte in der Infobox sowohl einen Unter- als auch einen Überstrich. Leider habe ich auch keine Idee, wie man Konqueror (bzw. Safari) dazu bringt, das "underline" des übergeordneten Elements auszuschalten :/

PS: wegen dem IE schau ich später nochmal

02.09.2007 18:07 | geändert: 02.09.2007 18:10

9 Jörg

So, jetzt hab ich mir die Top-Navigation im IE 7 angeschaut. Dass die Hintergrundfarbe nicht angezeigt wird, scheint wohl ein Bug zu sein, der mir auch schon früher begegnet war. Ich hatte festgestellt, dass eine border den IE dazu bringt, den Hintergrund anzuzeigen:

#head ul li a:hover {
	color: #000;
	background-color: #fff;
	text-decoration: none;
             border: 1px solid transparent;
}

Der IE 6 scheint das "#sidebar a.info:hover span" zu ignorieren; Problem bereitet ihm wohl das :hover des übergeordneten Elements - ohne dem zeigt es die letzte Info-Box an. Da dieses Problem im IE 7 nicht mehr auftritt, handelt es sich wohl um einen Bug - wie man diesen beheben könnte, weiß ich leider nicht

02.09.2007 21:33

10 kadees

Hallo Jörg,
Der Ansatz mit
border: 1px solid transparent;
wars, der hat mit noch gefehlt. Allerdings verursachte '1px solid transparent' bei mir ein 'hüpfen' beim hovern.
Mit
border: none;
funktionierts jetzt einwandfrei.

Was ich nicht verstehe beim IE6 ist, dass in meinem Tipp die Infoboxen angezeigt werden, nicht jedoch in der Sidebar. Und das bei gleichem Code, sowohl HTML als auch CSS. Oder hab ich da was übersehen?

Gruß Dieter

02.09.2007 22:09