Zur Navigation

Vorsicht Greenhorn

1 Fanny

Hallo!

Als blutiger Anfänger habe ich mich nun durch unzälige Supportforen,Webseiten usw geknabbert. Mit dem Erfolg, das ich nun völlig überfordert und verwirrt bin und nur noch Bahnhof verstehe. Ich habe auf www.anders-welten.de ein wbb2 Forum und ich befürchte, das ich inzwischen mehr Fehler rein als raus gebastelt habe. Vieleicht könnte mal jemand, der etwas mehr Ahnung hat als ich, kurz drauf gucken und mir sagen, wo die ganz groben Schnitzer sind?

Vielen Dank!
Fanny

07.10.2008 12:14

2 Jörg

Hallo Fanny,

Vom Optischen her finde ich den Header nur schwer lesbar - ich würde die Schrift dort vielleicht etwas dicker gestalten.

Hinsichtlich Suchmaschinenoptimierung sind die Session-IDs in den Adressen ungünstig - dadurch erhalten die Suchmaschinenbots die Inhalte bei jedem Besuch unter einer anderen Adresse.

Das sind zwei Punkte, die mir auf Anhieb auffielen

07.10.2008 13:12

3 Fanny

Vielen Dank, für die superschnelle Antwort!
Bei "Session-IDs" erscheinen vor meinem inneren Auge 1000 Fragezeichen ;-) Das ist auch etwas, was ich noch nicht verstanden habe. In meiner Datenbank wird die Tabelle bb1_sessions als unknown angezeigt. Hat das damit etwas zu tun? Und wie kann man das Problem beheben? Sorry, für meine vieleicht dummen Fragen, aber wie gesagt ich bin Anfänger, aber durchaus willens und in der Lage dazu zu lernen.

07.10.2008 13:32

4 Jörg

Hier ist zu lesen, dass die Session-ID ab der Version 2.2 gegenüber Googlebot ausgeblendet wird.

Desweiteren hat sich am wBB 2.2 noch eine ganze Menge am Session-System geändert, z.B. wird die Session-ID bei Bots (z.B. Googlebot) oder bei eingeloggten Benutzern, die Cookies verwenden, gänzlich ausgeblendet.

Warum das bei deinem Board nicht der Fall ist, kann ich nicht sagen, denn anscheinend verfügst du bereits über Version 2.3.5? Ich würde in diesem Fall im Supportforum von Woltlab nachfragen, die können dazu sicher mehr schreiben

07.10.2008 14:01 | geändert: 07.10.2008 14:03

5 Fanny

Dazu hab ich jetzt folgendes gefunden:

Im wBB 2.3.5 gibt es keine Option mehr, ob der Benutzer Cookies verwenden möchte oder nicht. Das wBB erkennt dies automatisch.

Wenn es nicht möglich ist, einen Cookie auf dem PC zu speichern, wird eine Session ID an den Link angehangen. Andernfalls wird die Session in den Cookies gespeichert.

Dies geht aber erst nach dem ersten Klick im Forum. Also beim ersten Klick hat man noch eine Session ID am Link, danach wird das Cookie, falls möglich, benutzt.

Für Suchmaschinenbots gibt es ja das Archiv, in dem die Links speziell aufbereitet sind.

Womit ich nun wieder bei dem Problem angekommen bin, das mein Archiv nicht funktioniert.
Habe nun folgen Rat befolgt:
Du kannst aber auch im Template dafür sorgen, dass Gäste keine Sid haben.

Template suchen und ersetzen:
suchen: {$SID_ARG_2ND}
ersetzen: <if($wbbuserdata['userid'])><then>{$SID_ARG_2ND}</then></if>

suchen: {$SID_ARG_1ST}
ersetzen: <if($wbbuserdata['userid'])><then>{$SID_ARG_1ST}</then></if>

hat den gleichen Effekt.

Leider kann ich aber nicht erkennen, ob das etwas gebracht hat oder ob ich die ganze Sache jetzt noch verschlimmert hab.

07.10.2008 15:04

6 Jörg

Die Session-IDs sind weg.

http://www.anders-welten.de/thread.php?threadid=377

Vorher hing da noch ein "&sid=irgendwas" hintendran - das war die Session-ID. Das Problem scheint also gelöst

07.10.2008 15:08

7 Fanny

Prima, ich bedanke mich wie doll und verrückt :-)

07.10.2008 15:16

8 Fanny

Da bin ich olle Nervensäge schon wieder mit einer Anfängerfrage. Ob sich bitte mal jemand meine meta-tags ansehen könnte? Das wurde mir so geraten und weil ich keine Ahnung habe, hab ich es so gemacht und gehofft, es wird schon richtig sein. Nun war ich mal ein bißchen rumschnüffeln und mir drängt sich der leise Verdacht auf, das ich so ziemlich die einzige bin, die so viel drin stehen hat.

09.10.2008 20:53

9 Jörg

Von den folgenden reicht die erste Meta-Angabe:

<meta name="robots" content="all"/>
<meta name="robots" content="index,follow"/>
<meta name="googlebot" content="index,follow"/>
<meta name="robots" content="Aladin"/>
<meta name="robots" content="scooter"/>
<meta name="robots" content="Crawler"/>
<meta name="robots" content="Eule-Robot"/>
<meta name="robots" content="excite"/>
<meta name="robots" content="Flipper/1.1"/>
<meta name="robots" content="Mariner"/>
<meta name="robots" content="Lycos"/>
<meta name="robots" content="Yahoo"/>
<meta name="robots" content="Fireball"/>
<meta name="robots" content="Altavista"/>
<meta name="robots" content="Lotse"/>

<meta name="robots" content="Web.de"/>
<meta name="robots" content="Infoseek"/>
<meta name="robots" content="Metacrawler"/>

Die übrigen sind redundant oder unsinnig

Auch diese ist doppelt - einmal reicht:

<meta http-equiv="Content-Type" content="text/html; charset=windows-1252" />

Hier würde denke ich auch eine ausreichen:

<meta name="author" content="FannyDeWinter"/>
<meta name="publisher" content="FannyDeWinter"/>
<meta name="copyright"   content="FannyDeWinter"/>

09.10.2008 23:04 | geändert: 09.10.2008 23:06

Nur Mitglieder können in diesem Forum Antworten schreiben.

Login | Registrieren