Zur Navigation

Probleme mit Sonderzeichen bzw. Umlautzeichen

1 User 510 (Ex-Mitglied)

Guten Morgen!

Wir haben zurzeit nachfolgendes Problem und hoffen auf eine zündende Idee aus dieser Runde... ;-)

Nachrichtenartikel unserer Website werden bezüglich Sonderzeichen korrekt ausgegeben (Website, Google, Google-News, RSS und via RSS-Feed über Twitterfeed an Facebook).

Wenn aber Jemand unter dem Artikel auf den "Gefällt mir-Button" drückt oder die Artikel-Url direkt bei Facebook postet, werden diese Zeichen nicht erkannt (ä, ö, ü, Kommas, Klammern etc.). --> siehe: screenshot
Nach einigem "Rumprobieren" fällt uns nun nichts mehr ein.

Vielleicht hat hier noch Jemand einen Ansatz für uns?

30.06.2011 09:49 | geändert: 30.06.2011 10:38

2 Jörg

Facebook liest wohl die Open Graph Meta-Angaben aus:

<meta property="og:site_name" content="Nachrichten und Meinungen aus Nordost | Stralsund" />
		<meta property="og:url" content="http://www.stralsund-intern.de/sport/00473/Ruegen-Auswahl-gegen-Schalke-04-ueberfordert.html" />
		<meta property="og:image" content="http://www.stralsund-intern.de//mediacontent/img11_13066914230-125.jpg" />

		<meta property="og:type" content="article" />
		<meta property="og:title" content="Rügen-Auswahl gegen Schalke 04 überfordert" />

Möglicherweise ist Facebook zu doof, die Meta-Angabe "content-type" zu berücksichtigen, und erwartet grundsätzlich die Codierung UTF-8.

Ich würde den Inhalt von og:title mal mit htmlentities() behandeln und schauen, ob Facebook die Daten dann korrekt übernehmen kann.


Edit:
den Screenshot habe ich verpasst - der Titel scheint dann ja korrekt wiedergegeben zu werden und ist gar nicht das Problem? Wie wäre es, wenn Ihr auch den Anriss in einer Metaangabe "og:description" übergebt?

30.06.2011 11:11 | geändert: 30.06.2011 11:19

3 User 510 (Ex-Mitglied)

Guter Tipp. Jetzt klappt es. Danke Jörg!

30.06.2011 13:33

Beitrag schreiben (als Gast)

Beim Verfassen des Beitrages bitte die Forenregeln beachten.





[BBCode-Hilfe]