Zur Navigation

SSL Verschlüsselung aktiviert & Beiträge und Links können nicht mehr aufgerufen

2 Jörg

Die Unterseiten senden einen HTTP-Status-Code 404 und im HTML-Code ist ein Iframe von Sedo-Parking integriert.

Wird die .htaccess Datei unter https nicht beachtet?

26.05.2018 15:23 | geändert: 26.05.2018 15:24

3 krieger98

Zitat von Jörg
Die Unterseiten senden einen HTTP-Status-Code 404 und im HTML-Code ist ein Iframe von Sedo-Parking integriert.

Wird die .htaccess Datei unter https nicht beachtet?
Das weiß ich nicht.
Die .htaccess sieht so aus:
RewriteEngine on
RewriteBase /
RewriteCond %{QUERY_STRING} !^$
RewriteCond %{THE_REQUEST} /index\.php
RewriteRule ^index\.php$ - [G,L]
RewriteCond %{QUERY_STRING} ^$
RewriteCond %{THE_REQUEST} /(.*)index\.php
RewriteRule ^index\.php$ http://%{HTTP_HOST}/%1 [R=301,L]
RewriteRule ^feeds/(1-0|2-0|atom)\.xml$ index.php?t=$1 [L,QSA]
RewriteRule ^sitemap\.xml$ index.php?t=sitemap [L]
RewriteRule ^trackback-([0-9]+)-([0-9]+)-(.+)\.xml index.php?t=trackback&tid=$1&uid=$2&tbid=$3 [L]
RewriteRule ^(.+)-(f|t|u)-([0-9]+)-([0-9]+)$ index.php?o=$2&n=$1&id=$3&p=$4
RewriteRule ^neue-beitraege-([0-9]+)$ index.php?o=p&p=$1
RewriteRule ^sitemap-([0-9]+)$ index.php?o=sitemap&p=$1
RewriteRule ^archiv-([0-9]+)$ index.php?o=t&p=$1
RewriteRule ^userliste-([0-9]+)$ index.php?o=u&p=$1
RewriteRule ^edit/([a-z]+)-([0-9]+)$ index.php?z=edit&o=$1&id=$2 [QSA]
RewriteRule ^new/([a-z]+)$ index.php?z=new&o=$1 [QSA]
RewriteRule ^(admin|mods|suche)$ index.php?z=$1 [QSA]
RewriteRule ^(login|logout)$ index.php?z=$1
RewriteRule ^info/([a-z]+)$ index.php?o=$1 [L,QSA]
RewriteRule ^scripts/bbcode-([0-9]+)-[0-9a-f]{4}\.js$ scripts/bbcode.php?t=js&vars=$1
RewriteRule ^styles/(.+)-v[0-9]+\.css$ styles/$1.css

# Komprimierung von css und js Dateien:
# RewriteRule \.(css|js)$ compress.php

Ich habe nur die SSL aktiviert sonst nichts gemacht.
Können Sie am Montag mal aktiv werden damit das wieder klappt?

26.05.2018 15:59 | geändert von Jörg: 26.05.2018 16:14

4 Jörg

Bei 1und1 gibt es des öfteren Probleme mit der RewriteBase Direktive. Ich würde diese mal auskommentieren:

# RewriteBase /

Die Einstellungen für https://forum.fahrrad-workshop-sprockhoevel.de nimmt 1und1 möglicherweise in einem anderen VirtualHost-Container vor als für http://forum.fahrrad-workshop-sprockhoevel.de, und vielleicht ist dort dann was anderen eingestellt, was verhindert, dass die mod_rewrite Regeln wie gewünscht zur Ausführung kommen.

Können Sie am Montag mal aktiv werden damit das wieder klappt?

Wenn das bis dahin nicht behoben ist, ja.

26.05.2018 16:23

5 krieger98

Zitat von Jörg
Bei 1und1 gibt es des öfteren Probleme mit der RewriteBase Direktive. Ich würde diese mal auskommentieren:

# RewriteBase /

Die Einstellungen für https://forum.fahrrad-workshop-sprockhoevel.de nimmt 1und1 möglicherweise in einem anderen VirtualHost-Container vor als für http://forum.fahrrad-workshop-sprockhoevel.de, und vielleicht ist dort dann was anderen eingestellt, was verhindert, dass die mod_rewrite Regeln wie gewünscht zur Ausführung kommen.
Können Sie am Montag mal aktiv werden damit das wieder klappt?
Wenn das bis dahin nicht behoben ist, ja.
Danke !!!
1und1 das Problem heute behoben.

27.05.2018 12:34

6 Jörg

Ich würde noch die kanonische URL auf https:// ändern:

<link rel="canonical" href="http://forum.fahrrad-workshop-sprockhoevel.de/" />

Das lässt sich in JKBB einstellen im Adminbereich unter Administration -> Allgemein -> Kanonische URL

27.05.2018 17:26

Beitrag schreiben (als Gast)





[BBCode-Hilfe]