IE Bug beim CSS Button

Hallo,
ich habe folgenden Button-Code:

a.schalter {
color:#000; background-color:#B0E0E6;
border-left:2px solid #fff; border-top:2px solid #fff;
border-right:2px solid #000; border-bottom:2px solid #000;
width:800px;
padding:7px;
font-size:18px;
font-family:Verdana, Arial, sans-serif;
text-decoration:none;
text-align:center;
margin:10px;
background-image:url(slides/barrierefreirot.gif);
background-repeat: no-repeat;
background-position: 0 center;
padding-left: 110px;
display:block;
}

a.schalter:hover {
color:#000; background-color:#48D1CC;
border-left:2px solid #666; border-top:2px solid #666;
border-right:2px solid #ccc; border-bottom:2px solid #ccc;
padding-left: 110px;
margin:10px;
background-image:url(slides/barrierefrei.gif);
background-repeat: no-repeat;
background-position: 0 center;
padding-left: 110px;
}

HTML:
<a style="text-align: center; margin-left: auto; margin-right: auto;"
class="schalter"
title="barrierefreie Seite, für Menschen mit Sehbehinderungen"
href="index_barrierefrei.html" ="">&gt;&gt;&gt;
Hier
können Sie die Seite in einfacher Schrift (barrierefrei) aufrufen</a>

Auf der Seite www.Muehlenferienhaus.de.

Problem:
Wenn ich (beim IE) mit dem Button zur nächsten Seite springe und wieder zurück ist der Hintergrund weiss. Erst beim rüber gehen kommt wieder Farbe. Beim Firefox passiert das nicht.

Gibt es dafür ein workaround?

Gruss
Uwe

08.08.2007 07:08


Hallo Uwe,

möglicherweise verwendet der IE hier die Eigenschaften von a:active, die nicht extra definiert sind (obwohl a.schalter eigentlich alles abdecken sollte)? Definier probehalber mal zusätzlich a.schalter:active mit dem entsprechenden Hintergrundbild

 a.schalter:active {
  background-image:url(slides/barrierefreirot.gif);
}

08.08.2007 09:01 | geändert: 08.08.2007 09:02


Hallo,
danke für die Info,

Bei mir scheint es jetzt mit

a.schalter:active {
color:#000; background-color:#B0E0E6;
background-image:url(slides/barrierefreirot.gif);
background-repeat: no-repeat;
background-position: 0 center;
padding-left: 110px;
}

zu klappen.

Funktioniert es bei euch auch?

Gruss
Uwe

08.08.2007 18:45


Teilen:

Beitrag schreiben (als Gast)

Beim Verfassen des Beitrages bitte die Forenregeln beachten.


[BBCode-Hilfe]