Zur Navigation

Link werden im FF nicht richtig dargestellt

1 tobi

hallo zusammen,

es ist dass erste mal, dass mir der ff probleme bereitet und der ie nicht :)

wie man im screen sieht, werden die grafiken unterstrichen.
die grafiken und den text habe ich verlinkt.

siehe screen:
http://ttc-tobi.bplaced.net/screen_links.JPG

mein css code:

/* Links allgemein - Link Angaben 1 */
a.links {
font-size:13px;
text-decoration:underline;
color:#000;
}

/* Links allgemein - Link Angaben 2 */
a.links:hover {
text-decoration:underline;
color:#FFA54F;
}

/* Bilder bei Links nicht unterstreichen */
a img {
border:none;
text-decoration:none;
}

und hier noch ein auszug aus der php datei:

echo "<table class=\"table_zentrieren\" width=\"100%\" border=\"0\" cellpadding=\"0\" cellspacing=\"2\">\n";
echo "<tr>\n";
echo "<td><table class=\"table_linkseite\"><tr><td><a class =\"links\" rel=\"oeffneneuesfenster\" href=\"http://www.tt-maximus.de/\" title=\"Hamburg TTV\">Hamburg TTV<br /><br/><img src=\"bilder/links/hamburger_tt_verband.gif\" width=\"97\" height=\"99\" alt=\"Hamburg TTV\" /></a></td></tr></table></td>\n";
echo "<td><table class=\"table_linkseite\"><tr><td><a class =\"links\" rel=\"oeffneneuesfenster\" href=\"http://www.httv.de/\" title=\"Hessischer TTV\">Hessischer TTV<br/><br/><img src=\"bilder/links/hessischer_tt_verband.gif\" width=\"73\" height=\"100\" alt=\"Hessischer TTV\" /></a></td></tr></table></td>\n";
echo "<td><table class=\"table_linkseite\"><tr><td><a class =\"links\" rel=\"oeffneneuesfenster\" href=\"http://www.pttv.de/\" title=\"Pf&auml;lzischer TTV\">Pf&auml;lzischer TTV<br /><br/><img src=\"bilder/links/pfaelzer_tt_verband.gif\" width=\"75\" height=\"100\" alt=\"Pf&auml;lzischer TTV\" /></a></td></tr></table></td>\n";
echo "<td><table class=\"table_linkseite\"><tr><td><a class =\"links\" rel=\"oeffneneuesfenster\" href=\"http://www.rttv.de/\" title=\"Rheinhessischer TTV\">Rheinhessischer TTV<br /><br/><img src=\"bilder/links/rheinhessischer_tt_verband.gif\" width=\"98\" height=\"100\" alt=\"Rheinhessischer TTV\" /></a></td></tr></table></td>\n";
echo "<td><table class=\"table_linkseite\"><tr><td><a class =\"links\" rel=\"oeffneneuesfenster\" href=\"http://www.ttvr.de/\" title=\"Rheinland TTV\">Rheinland TTV<br /><br/><img src=\"bilder/links/rheinland_tt_verband.gif\" width=\"145\" height=\"73\" alt=\"Rheinland TTV\" /></a></td></tr></table></td>\n";
echo "</tr>\n";

wie gesagt, der ie hat keine probleme damit, der zeigt die grafik nicht unterstrichen an, nur der ff

mfg tobi

13.11.2009 19:28 | geändert: 13.11.2009 19:29

2 Jörg

Mit dem Selektor "a img" definierst du das Aussehen des Bildes innerhalb des Links. Die Unterstreichung gehört aber zum Link, nicht zum Bild. Von daher verhält sich Firefox hier korrekt.

Du kannst Text und Bilder ja getrennt verlinken, und die Links entsprechend mit zwei verschiedenen Klassen kennzeichnen.

13.11.2009 21:42

3 tobi

ich wollte mir die arbeit erleichertern und beides in einem verlinken, aber ic hwerd wohl nicht drum herum kommen text und bild zu trennen.

14.11.2009 00:55

Beitrag schreiben (als Gast)





[BBCode-Hilfe]