Zur Navigation

Umleitung einer alias Domain auf statischen Inhalt - Typo3 Installation htaccess [2]

11 Lars (Gast)

Hier die htaccess

### Begin: Rewrite stuff ###

# Enable URL rewriting
RewriteEngine On


RewriteBase /
RewriteRule ^typo3$ - [L]
RewriteRule ^typo3/.*$ - [L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-s
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule .* index.php
RewriteRule ^(.*)\.htm$ /index.php



RewriteRule ^(typo3|t3lib|tslib|fileadmin|typo3conf|typo3temp|uploads|showpic\.php|favicon\.ico|Marco-Formisano)/ - [L]

Im Unterverzeichnis gibt es keine. Die URL lautet "www.sfb-antike.de/Marco-Formisano"

17.11.2010 21:45

12 Jörg

Die Ausnahmeregel sollte möglichst weit oben (unterhalb der RewriteBase Direktive) angebracht werden, sonst kommt sie nicht mehr zum Zuge.

17.11.2010 22:15

13 Lars (Gast)

Jetzt steht sie an erster Stelle. Habe heute auch das realurl Update auf 1.10.1 installiert.

Hast Du noch weitere Ideen?

18.11.2010 17:58

14 Jörg

Die URL lautet "www.sfb-antike.de/Marco-Formisano"

Funktioniert doch?

18.11.2010 18:22

15 Lars (Gast)

Ja, ich habe es gestern Abend auch gemerkt - hatte aber keine Zeit mehr zu posten. Nachdem ich den Ordner eine Ebene höher abgelegt hatte und die Verknüpfung über einen symbolischen Link hergestellt habe, konnte ich die Seite wieder aufrufen. Wäre es möglich, dass Deine Ausnahmeregel mit dieser Variante besser greift? Ich kann es mir nicht erklären - bin aber sehr froh, dass es wieder funktioniert und bedanke mich sehr für die Hilfe!!!

MfG Lars

19.11.2010 14:06

16 Jörg

Nachdem ich den Ordner eine Ebene höher abgelegt hatte und die Verknüpfung über einen symbolischen Link hergestellt habe, konnte ich die Seite wieder aufrufen.

Sorry, da kann ich dir jetzt nicht ganz folgen: welchen Ordner hast du eine Ebene höher verschoben? und von wo hast du wohin einen symbolischen Link gesetzt?

Wäre es möglich, dass Deine Ausnahmeregel mit dieser Variante besser greift? Ich kann es mir nicht erklären

Möglicherweise stimmte die RewriteBase Direktive nicht. Diese sollte den Pfad des betreffenden Verzeichnisses relativ zum DocumentRoot-Verzeichnis vermerken. Bei der Angabe "/" sollte die htaccess Datei direkt im DocumentRoot-Verzeichnis liegen.

19.11.2010 14:25 | geändert: 19.11.2010 14:26

17 Lars (Gast)

Den Ordner Marco-Formisano habe ich jetzt unter "var/www" abgelegt und nicht mehr im T3- VZ des Webservers. In diesem liegt jetzt der s-link.

19.11.2010 14:39

Beitrag schreiben (als Gast)

Beim Verfassen des Beitrages bitte die Forenregeln beachten.





[BBCode-Hilfe]