Zur Navigation

Eigene Ordner für Alias-Domains

1 Chris (Gast)

Hi Jörg

Ich habe jetzt alle Beiträge in diesem Thread durchgeschaut, nur leider nicht das gefunden, was ich suche.

Ich habe 3 Domains, aber leider nur einen Webspace.

www.domain1.de - ist direkt auf dem Host eingerichtet
www.domain2.de - scheint nur ein alias zu sein
www.domain3.de - scheint nur ein alias zu sein

Ich möchte jetzt im root Ordner anlegen (domain1.de; domain2.de; domain3.de) und mittels .htaccess erreichen, dass bei Aufruf jeder einzelnen Domain direket der jeweilige Ordner sozusagen als root fungiert.

Vielen Dank im Voraus.
Gruß Chris

12.08.2009 17:32

2 Jörg

Ich habe 3 Domains, aber leider nur einen Webspace.

Aber hast du nicht die Möglichkeit, jeder Domain einen eigenen DocumentRoot-Ordner zuzuordnen - z.B. über das Konfigurationsmenü deines Webspaces? Viele Webhoster bieten so eine Möglichkeit an.

Mit Modrewrite ginge so etwas zwar auch, aber eine direkte Zuordnung würde ich hier in jedem Fall vorziehen.

Das ist ungetestet:

RewriteEngine on

RewriteCond %{HTTP_HOST} (domain1\.de|domain2\.de|domain3\.de)$
RewriteRule ^(.*)$ %1/$1

12.08.2009 18:17

3 Chris (Gast)

Hi Jörg

Leider habe ich nicht die Möglichkeit jeder Domain einen eigenen DocumentRoot-Ordner zuzuordnen.

RewriteEngine on
RewriteCond %{HTTP_HOST} (domain1\.de|domain2\.de|domain3\.de)$
RewriteRule ^(.*)$ %1/$1

funktioniert leider nicht :( ...

Da bekomme ich bei der Hauptdomain jetzt Internal Server Error (500).
Bei den Aliasen leider nur eine leere Seite.

Übrigens läuft im Hintergrund Plesk 8.6 als Controlpanel und der vhost ist auf der Hauptdomain (domain1.de) konfiguriert.

Vielen Dank.

Viele Grüße Chris

12.08.2009 18:56

4 Jörg

Vermutlich läuft hier auch wieder eine Endlosschleife.

So könnte es vielleicht gehen:

RewriteEngine on
RewriteCond %{HTTP_HOST} (domain1\.de|domain2\.de|domain3\.de)$
RewriteCond %{REQUEST_URI} !(domain1\.de|domain2\.de|domain3\.de)
RewriteRule ^(.*)$ %1/$1

Willst du in den Unterordnern auch Modrewrite einsetzen? es ist nicht auszuschließen, dass das dann so nicht mehr funktioniert - aber bei statischen Seiten sollte es eigentlich so gehen.

12.08.2009 20:02

5 Chris (Gast)

Sooo, die Vermutung mit der Endlosschleife war gar nicht so verkehrt.

Der 500er ist schon mal weg und alles scheint zu funktionieren... werde eventuelle Fehler posten, falls welche auftauchen sollten.

Schon mal dafür vielen Dank!

In einem Unterordner muss ich in Zukunft ModRewrite einsetzen, da ich dort dynamisch generierte in SEO-URLs umschreiben lassen möchte.

13.08.2009 07:46

Beitrag schreiben (als Gast)





[BBCode-Hilfe]