Zur Navigation

Umschreiben einer URL / Umleiten hab ich schon geschafft! [2]

11 Jörg

Wenn das mit der Angabe der RewriteBase auch nicht funktioniert, würde ich den Webhoster fragen, wie du es bewerkstelligen kannst, dass die Domain mit dem Inhalt dieses Unterverzeichnisses angezeigt wird. Normalerweise funktioniert das wie beschrieben. Es könnten hier aber auch Modrewrite Regeln in der Serverkonfiguration o.ä. dazwischenfunken

25.05.2010 19:43

12 KoCall_Marketing

Ich glaub irgendwie werd ich nicht richtig verstanden!

Es wird doch der richtige inhalt angezeigt mit der .htaccess die ich mir selber zusammengeschnitzt habe.

nur in der zeile ändert sich die adresse, und ich will aber das die adresse stehen bleibt!

25.05.2010 19:46

13 Jörg

Es wird doch der richtige inhalt angezeigt mit der .htaccess die ich mir selber zusammengeschnitzt habe.

Und wo habe ich geschrieben, dass das nicht der Fall ist?

nur in der zeile ändert sich die adresse, und ich will aber das die adresse stehen bleibt!

... und genau darauf bezog ich mich:

dass die Domain mit dem Inhalt dieses Unterverzeichnisses angezeigt wird.

Unter der Domain test.at wird der Inhalt im Verzeichnis test nicht angezeigt. Nur unter der Domain server.at.

25.05.2010 20:00

14 KoCall_Marketing

Zitat von Jörg

Unter der Domain test.at wird der Inhalt im Verzeichnis test nicht angezeigt. Nur unter der Domain server.at.

doch der inhalt wird richtig angezeigt!

Zitat von Jörg
würde ich den Webhoster fragen, wie du es bewerkstelligen kannst, dass die Domain mit dem Inhalt dieses Unterverzeichnisses angezeigt wird

Der provider supportet das nicht!

25.05.2010 20:11

15 Jörg

Zitat von KoCall_Marketing
Zitat von Jörg

Unter der Domain test.at wird der Inhalt im Verzeichnis test nicht angezeigt. Nur unter der Domain server.at.

doch der inhalt wird richtig angezeigt!

Schön, dann ist das Problem ja gelöst.

25.05.2010 20:17

16 KoCall_Marketing

nein ist es nicht! das problem liegt ja nicht am inhalt, sondern das sich die url in der zeile ändert! und die sollte aber stehenbleiben! du siehst es ja selber wenn du die adresse eingibst im browser das sie sich ändert!

25.05.2010 20:22

17 Jörg

Ich meine schon genau das gleiche wie du - aber du willst mich anscheinend mit aller Gewalt missverstehen.

Wenn ich sage, dass ein Inhalt unter einer Domain angezeigt wird, beinhaltet das, dass in der Adresszeile der Name eben dieser Domain dauerhaft zu sehen ist (und nicht, dass er nur vor ein paar Sekunden zu sehen war). Eine Weiterleitung ist eben etwas anderes. Ich kann auch von einer meiner Domains zu Google weiterleiten - dadurch wird der Inhalt von Google aber nicht unter meiner Domain angezeigt.

Was wird eigentlich (inhaltlich und in der Adresszeile) angezeigt, wenn du die htaccess löschst und www.test.at/test/ in deinem Browser eingibst?

25.05.2010 20:31 | geändert: 25.05.2010 20:32

18 KoCall_Marketing

ok ich meinte jedoch den inhalt des browserfensters und nicht den inhalt der adresszeile!


ohne .htaccess wird das richtige im browserfenster angezeigt! wenn ich www.test.at/test/ allerdings bleibt es auch stehen ich will jedoch das www.test.at steht und nicht www.test.at/test/ da auch im google und überall www.test.at schon bekannt ist!


das war ja auch schon mein ursprüngliches problem, das nicht das in der adresszeile steht was stehen soll ;-)

25.05.2010 20:54 | geändert: 25.05.2010 20:56

19 Jörg

wenn ich www.test.at/test/ allerdings bleibt es auch stehen ich will jedoch das www.test.at steht und nicht www.test.at/test/ da auch im google und überall www.test.at schon bekannt ist!

Dafür gibt es im Prinzip drei Lösungswege.

1. dass jeder Domain in der Webspace-Konfiguration ihr eigener DocumentRoot Ordner zugewiesen wird; das ist eigentlich der ideale Weg - aber nicht alle Webhoster bieten das wohl an; du hattest meine Frage danach zwar nicht beantwortet, aber ich gehe davon aus, dass du diese Möglichkeit nicht hast?

2. mit Modrewite kann man behelfsweise so eine Zuordnung realisieren; die übliche Vorgehensweise habe ich in Beitrag 9 beschreiben; warum das in deinem Fall so nicht funktioniert, kann ich nicht sagen - irgendwas in der Webserverkonfiguration deines Webspaces wird da wohl querschlagen; da kann man dann leider nicht viel machen, wenn der Webhoster hierbei keinen Support leistet

3. die Zielseite framen; das hat aber natürlich andere Nachteile und ist von daher auch nicht unbedingt empfehlenswert

Alternativ könntest du vielleicht eine 301 Weiterleitung von www.test.at/ nach www.test.at/test/ legen? die Adresse ändert sich dann zwar, aber die Besucher gehen dir nicht verloren und auch die Linkkraft der Startseite wird auf den Unterordner vererbt; und zumindest der Domainname in der URL bleibt erhalten

25.05.2010 21:16 | geändert: 25.05.2010 21:19

20 KoCall_Marketing

1. dass jeder Domain in der Webspace-Konfiguration ihr eigener DocumentRoot Ordner zugewiesen wird; das ist eigentlich der ideale Weg - aber nicht alle Webhoster bieten das wohl an; du hattest meine Frage danach zwar nicht beantwortet, aber ich gehe davon aus, dass du diese Möglichkeit nicht hast?



zu 1. diese möglichkeit habe ich nicht da die betreffende domain von einem anderen anbieter ist, und selbst wenn sie von meinem provider wäre würden die es nur mittels frameset machen, was aber nicht in meinem sinn ist!







2. Alternativ könntest du vielleicht eine 301 Weiterleitung von www.test.at/ nach www.test.at/test/ legen? die Adresse ändert sich dann zwar, aber die Besucher gehen dir nicht verloren und auch die Linkkraft der Startseite wird auf den Unterordner vererbt; und zumindest der Domainname in der URL bleibt erhalten


zu 2. genau das hab ich ja gemacht mit der .htaccess, eben nur wie gesagt ist das ergebniss in der adresszeile nicht das was ich will!



mal sehen, ich hoffe nun noch das mir der anbieter der betreffenden domain vielleicht weiterhelfen kann mit der .htaccess, irgendwie muß es doch zu schaffen sein!

oder soll ich meinen provider fragen ob die irgendwas eingestellt haben das es nicht so gelingt wie ich will?

ps.: ich hatte bis vor einer woche noch nen windows host, dort war das problem nicht dort hat es mir der provider gemacht das es so war wie ich wollte, und auch suchmaschinenfreundlich ohne frameset.
Allerdings hab ich umgestellt auf linux webhost, und jetzt will der provider es nicht supporten mit der .htaccess echt arg!!

25.05.2010 21:26 | geändert: 25.05.2010 21:28