Zur Navigation

Nach Installation von KDE-neon fehlt Windows im Boot-Menü

1 Ranma (Gast)

Das Windows scheint futsch zu sein. Vielleicht läßt es sich nur nicht mehr booten. Das Installationsprogramm von KDE-neon hat eine Partition, die fast die gesamte Festplatte einnahm, auf die Hälfte verkleinert, um Platz für KDE-neon zu schaffen. Der Nummerierung nach war die Partition die dritte, außerdem ist die Hardware fast neu und abgesehen vom Herunterladen einiger ISO-Dateien hatte ich noch nichts damit gemacht. Also dürfte der verkleinerte Platz ziemlich leer gewesen sein und es hätte nichts vernichtet werden sollen. Im Boot-Menü fehlt Windows. Es gibt lediglich eine Option zur Wiederherstellung von Windows, die aber auch nur zu einer Fehlermeldung führt, weil ich dafür eine Recovery-Disk bräuchte. Dieser Menü-Eintrag läßt mich überhaupt erst annehmen, daß Windows beschädigt sein könnte und nicht nur im Boot-Menü vergessen.
Ranma

27.08.2017 01:32

2 Jörg

Um was für ein Boot-Menü handelt es sich - von GRUB?

Falls GRUB 2 als Bootloader fungiert, sollte auch os-prober installiert sein - dieses findet ggf. auch bootbare Windows-Partitionen

27.08.2017 13:34

3 Ranma (Gast)

Weil ein Name nicht dabeisteht, darum habe ich mich online auf die Suche gemacht und dabei erfahren, daß GRUB keine EFI-Partitionen findet. Ich hatte im BIOS alles auf Legacy setzen müssen, um von DVD booten zu können. EFI ist normal für neuere Computer mit Windows, also wird der Bootloader GRUB sein. Einem linuxerfahrenem Nutzer des Linustechtips-Forums ist es nicht gelungen, GRUB irgendwie dazu zu bewegen die Windows-Partition zu finden. Also ist es wohl hoffnungslos. Den Bootloader kann man wohl auch nicht austauschen?
Ranma

28.08.2017 04:00

4 Jörg

GRUB 2 unterstützt auch EFI. Siehe hierzu auch die Grundlagen von GRUB 2:

https://wiki.ubuntuusers.de/GRUB_2/Grundlagen/

Ich hatte im BIOS alles auf Legacy setzen müssen, um von DVD booten zu können.

Bei der Installation von KDE-neon?

Wenn Windows vorher über EFI gebootet wurde, wurde es vermutlich nicht auf einer klassischen MBR-Partition installiert, sondern auf einer GPT-Partition. Wenn bei der Installation von KDE-neon GRUB im BIOS-Modus installiert wurde, könnte das der Grund sein, dass GRUB die Windows-Installation nicht mehr findet, weil es dann nach klassischen MBR-Partitionen sucht.

Im Idealfall installiert man beide Betriebssystem im selben Modus (BIOS oder EFI). Allerdings soll Linux mit GRUB (im Gegensatz zu Windows) auch ohne EFI auf GPT-Partitionen installiert werden können. Das wäre u.U. vielleicht noch eine Option (wobei ich diesbezüglich keine Erfahrung habe)

28.08.2017 15:05 | geändert: 28.08.2017 15:07

5 Ranma (Gast)

Bei der Installation von KDE-neon?

Schon vorher. Generell. Erst hatte ich nur die Boot-Reihenfolge angepaßt. Das führte zu einem Versuch von DVD zu booten, der von irgendetwas abgebrochen wurde, weil von DVD (oder USB oder sonst irgendetwas außer der Festplatte) zu booten gegen Sicherheitseinstellungen verstieß. Das war also schon werksseitig unmöglich. Ins BIOS zu kommen war bereits schwierig (nur noch über ein kleines, versenktes Knöpfchen an der Seite des Laptops, das man nur mit einer aufgebogenen Büroklammer erreichen kann und nur reagiert, wenn man es wirklich präzise und nicht zu stark und nicht zu schwach trifft).

Eine Installation im EFI-Modus ist also unmöglich, weil booten vom Installationsmedium in dem Fall unmöglich ist. Andererseits müßte im EFI-Modus installiert werden, wenn Windows weiterhin gefunden werden soll. Möglicherweise müßte ich nun jedesmal je nach gewünschtem Betriebssystem den Modus im BIOS (steht immernoch auf Legacy, weil sich das wohl kaum während des Installationsvorgangs verändern läßt) umstellen. Das habe ich noch nicht ausprobiert.
Ranma

29.08.2017 01:25

6 Jörg

Das führte zu einem Versuch von DVD zu booten, der von irgendetwas abgebrochen wurde, weil von DVD (oder USB oder sonst irgendetwas außer der Festplatte) zu booten gegen Sicherheitseinstellungen verstieß.

Dabei handelt es sich um die UEFI-Funktion Secure Boot; im Wiki von ubuntuusers ist für zwei gängige BIOS-Hersteller beschrieben, wie man dies abschalten kann:

https://wiki.ubuntuusers.de/EFI_Grundlagen/#Secure-Boot

Falls dein Rechner über ein anderes BIOS verfügt, müsste man im Netz nach einer Anleitung suchen.

29.08.2017 14:15 | geändert: 29.08.2017 14:16

7 Ranma (Gast)

Wenn ich im BIOS den einen Eintrag Legacy first auf uEFI first ändere, dann wird beim booten, ohne den Umweg über ein Boot-Menü, Windows geladen.

Ich bekomme also entweder nur Windows oder nur KDE-neon oder ich muß jedesmal per aufgebogener Büroklammer den Umweg über das BIOS nehmen.
Ranma

31.08.2017 07:16

8 Ranma (Gast)

Normalerweise sollte man von einem Linux-System zumindest auf die in einem parallelem Windows-System abgelegten Daten zugreifen können. Der Versuch führt aber zu folgender Fehlermeldung:

Beim Zugriff auf „Windows“ ist ein Fehler aufgetreten, die Meldung lautet: Die angegebene Operation ist fehlgeschlagen: Error mounting /dev/sda3 at /media/Ranma/Windows: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sda3" "/media/Ranma/Windows"' exited with non-zero exit status 14: Windows is hibernated, refused to mount.
Failed to mount '/dev/sda3': Vorgang nicht zulässig
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Ich habe schon versucht, den Befehl aus der Fehlermeldung in ein Terminal-Fenster zu kopieren und ihn um das ro vor oder nach dem -t zu ergänzen. Das hat jedoch nichts verändert.

Ich bin mir nichtmal sicher, ob die Fehlermeldung eigentlich besagen sollte, daß ich nicht auf eine Partition, die unter EFI erstellt wurde, zugreifen kann.
Ranma

31.08.2017 07:55

9 Jörg

exited with non-zero exit status 14: Windows is hibernated, refused to mount.

"hibernated" bedeutet, dass Windows nicht komplett heruntergefahren wurde, sondern sich nur im Ruhezustand befindet. Ein Zugriff auf das Dateisystem von Linux aus könnte dann dazu führen, dass Windows nicht mehr komplikationslos aus dem Ruhezustand aufwachen kann. Deswegen weigert sich mount, die Partition einzuhängen.

Ich habe schon versucht, den Befehl aus der Fehlermeldung in ein Terminal-Fenster zu kopieren und ihn um das ro vor oder nach dem -t zu ergänzen. Das hat jedoch nichts verändert.

Die Mount-Optionen werden der Kommando-Option -o in einer komma-separierten Liste übergeben, also muss das ro auch noch dort hinein:

-o "ro,uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000"

Ich bekomme also entweder nur Windows oder nur KDE-neon oder ich muß jedesmal per aufgebogener Büroklammer den Umweg über das BIOS nehmen.

Oder du installierst KDE-neon auch über EFI, nachdem du dort Secure Boot deaktiviert hast (siehe meinen letzten Beitrag)

31.08.2017 13:20 | geändert: 31.08.2017 13:22

10 Ranma (Gast)

"hibernated" bedeutet, dass Windows nicht komplett heruntergefahren wurde, sondern sich nur im Ruhezustand befindet.

Kann das überhaupt sein, wenn ich zwischendurch ein anderes Betriebssystem booten kann?

Oder du installierst KDE-neon auch über EFI, nachdem du dort Secure Boot deaktiviert hast (siehe meinen letzten Beitrag)

Laut dem Link stellt man das bei fast jedem System im BIOS ab. Einen entsprechenden Eintrag gibt es auch im BIOS vom Ideapad, aber diese Option hatte ich schon gleich abgestellt als ich das BIOS gefunden hatte. (Bei manchen Computern kann man erst danach von *uEFI* auf *Legacy* umstellen, so beschreibt es dein Link auf das Ubuntuusers-Wiki.) Nur EFI hat das irgendwie nicht interessiert. (Ist irgendwie auch logisch, wenn die Wahl zwischen BIOS und EFI die tiefere Schicht im Vergleich zur Einstellung des Secure-Boot ist.) Es muß irgendwo noch eine weitere, ähnliche Einstellung geben oder es läßt sich tatsächlich nichts anders machen.

Das Ubuntuusers-Wiki beschreibt wie man es schafft, ein Linux-Betriebssystem zu installieren. Das habe ich bereits geschafft. Jetzt ist das Problem nur noch, daß ich nicht zwischen KDE-neon und Windows im Boot-Menü auswählen kann. Zu diesem Problem habe ich nun im Ubuntuusers-Wiki noch einen Hinweis gefunden:

Hinweis:

Es darf kein Windows im EFI-Modus auf der gleichen Festplatte zusammen mit Ubuntu als Dualboot installiert sein. Windows verträgt ohne Nachbereitung keine Umstellung vom EFI-Modus auf BIOS-Modus. Auch ein Mischbetrieb aus EFI-Modus mit BIOS-Modus wird von GRUB 2 nicht unterstützt!

In diesem Fall sollte man für beide Betriebssysteme eine Neuinstallation im BIOS-Modus vornehmen oder das Windows vorab deinstallieren!

Ein Computer mit vorinstalliertem Windows kostet ungefähr hundert Euro mehr als einer ohne, deshalb finde ich es nicht akzeptabel, das im EFI-Modus vorinstallierte Windows zu deinstallieren und damit zu vernichten, um sich dann eine weitere Kopie zu kaufen, die man dann im BIOS-Modus installieren kann. Ich finde schon die hundert Euro einfach so zu vernichten nicht besonders akzeptabel und eigentlich eine Unverschämtheit, daß man das Betriebssystem nicht mehr auf einem extra beigelegtem Datenträger mitgeliefert bekommt. Aber zur Not reicht es auf die abgelegten Daten innerhalb der Windows-Sektion zugreifen zu können und für Windows-Programme mit Emulatoren zu experimentieren.

Aber es wundert mich sehr, daß nach dem Herunterfahren von Windows und anschließendem booten mit Umweg über das BIOS sich Windows im Ruhezustand befinden soll.
Ranma

01.09.2017 04:56